<!doctype html>
<html lang="en" style="display:block;min-width:1040px;">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="msvalidate.01" content="4DBAD5FE3F8EF00B87C0A8DB441E7D10" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="viewport" content="width=1040">
<meta name="norton-safeweb-site-verification" content="okou-yy-gm0gz23l60lejjw7wjoggo31os16krxr9sg66qisyil6vmcpg99hys2ctpxzks8m-e3dsmeaxiru5yxeq6-z-qveofpvczbag4-s6vtlx2pa3a9qa5c-vntn" />

<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link rel="stylesheet" href="https://use.typekit.net/nzi1lia.css">
<link rel="stylesheet" href="https://www.americanbankingnews.com/wp-content/themes/alambre/style.css?1530134534" type="text/css" media="screen, projection" />
<link href="https://www.americanbankingnews.com/feed" rel="alternate" title="American Banking News RSS Feed" type="application/rss+xml" />
<link href="https://www.americanbankingnews.com/feed/atom" rel="alternate" title="American Banking News Atom Feed" type="application/atom+xml" />
<link href="https://www.americanbankingnews.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="American Banking News &raquo; UBS Group Reaffirms Buy Rating for Compass Group (LON:CPG) Comments Feed" href="https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html/feed" />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.americanbankingnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.8' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><link rel='https://api.w.org/' href='https://www.americanbankingnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.americanbankingnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.americanbankingnews.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Cintas (CTAS) &#8211; Investment Analysts&#8217; Weekly Ratings Changes' href='https://www.americanbankingnews.com/2020/04/06/cintas-ctas-investment-analysts-weekly-ratings-changes.html' />
<link rel='next' title='BT Group &#8211; CLASS A (LON:BT.A) Given New GBX 190 Price Target at Goldman Sachs Group' href='https://www.americanbankingnews.com/2020/04/06/bt-group-class-a-lonbt-a-given-new-gbx-190-price-target-at-goldman-sachs-group.html' />
<meta name="generator" content="WordPress 5.0.8" />
<link rel="canonical" href="https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html" />
<link rel='shortlink' href='https://www.americanbankingnews.com/?p=14070279' />
<link rel="alternate" type="application/json+oembed" href="https://www.americanbankingnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.americanbankingnews.com%2F2020%2F04%2F06%2Fubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.americanbankingnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.americanbankingnews.com%2F2020%2F04%2F06%2Fubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html&#038;format=xml" />
<link rel="amphtml" href="https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html/amp" /><link rel="icon" href="https://www.americanbankingnews.com/wp-content/uploads/2017/09/favicon-american-banking-market-news.png" sizes="32x32" />
<link rel="icon" href="https://www.americanbankingnews.com/wp-content/uploads/2017/09/favicon-american-banking-market-news.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.americanbankingnews.com/wp-content/uploads/2017/09/favicon-american-banking-market-news.png" />
<meta name="msapplication-TileImage" content="https://www.americanbankingnews.com/wp-content/uploads/2017/09/favicon-american-banking-market-news.png" />
<script>
            (function(h,o,t,j,a,r){
                h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
                h._hjSettings={hjid:458696,hjsv:5};
                a=o.getElementsByTagName('head')[0];
                r=o.createElement('script');r.async=1;
                r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
                a.appendChild(r);
            })(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');
    </script>

<title>UBS Group Reaffirms Buy Rating for Compass Group (LON:CPG) - American Banking News</title>
<meta name="description" content="Compass Group (LON:CPG)&#8216;s stock had its &#8220;buy&#8221; rating reissued by equities research analysts at UBS Group in a note issued to investors on Monday, ThisIsMoney.Co.Uk reports. They currently have a GBX 1,705 ($22.43) price objective on the stock, down from their prior price objective of GBX 2,225 ($29.27). UBS Group&#8217;s price target indicates a potential [&hellip;]" />
<meta name="author" content="ABMN Staff">
<meta name="news_keywords" content="Compass Group,LON:CPG,CPG,Service,Reiterated Rating,UBS Group AG" />
<meta name="keywords" content="Compass Group,LON:CPG,CPG,Service,Reiterated Rating,UBS Group AG" />
<meta name="ticker" content="LON:CPG" />
<meta name="contentType" content="article">

<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="UBS Group Reaffirms Buy Rating for Compass Group (LON:CPG)" />
<meta name="twitter:description" content="Compass Group (LON:CPG)&#8216;s stock had its &#8220;buy&#8221; rating reissued by equities research analysts at UBS Group in a note issued to investors on Monday, ThisIsMoney.Co.Uk reports. They currently have a GBX 1,705 ($22.43) price objective on the stock, down from their prior price objective of GBX 2,225 ($29.27). UBS Group&#8217;s price target indicates a potential [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/compass-group-logo.png" />

<meta property="og:title" content="UBS Group Reaffirms Buy Rating for Compass Group (LON:CPG)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/compass-group-logo.png" />
<meta property="og:description" content="Compass Group (LON:CPG)&#8216;s stock had its &#8220;buy&#8221; rating reissued by equities research analysts at UBS Group in a note issued to investors on Monday, ThisIsMoney.Co.Uk reports. They currently have a GBX 1,705 ($22.43) price objective on the stock, down from their prior price objective of GBX 2,225 ($29.27). UBS Group&#8217;s price target indicates a potential [&hellip;]" />
<meta property="og:site_name" content="American Banking News" />
<meta property="og:locale" content="en_US" />

<meta property="article:published_time" content="2020-04-06T05:24:51+0000" />
<meta property="article:modified_time" content="2020-04-06T05:24:51+0000" />
<meta property="article:tag" content="LON:CPG" />
<meta property="article:tag" content="Compass Group,LON:CPG,CPG,Service,Reiterated Rating,UBS Group AG" />
<meta property="article:section" content="market-news" />


<script type='text/javascript'>var PopupAdChannel=''; </script>
<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>

<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13207898,
				sizes: [[300,250],[300,600]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'AmericanBankingNews_ROS_RightRail_1'
			});
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
</script>
<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>

<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>

<script type="application/javascript">(function(w,d,t,r,u){w[u]=w[u]||[];w[u].push({'projectId':'10000','properties':{'pixelId':'423827'}});var s=d.createElement(t);s.src=r;s.async=true;s.onload=s.onreadystatechange=function(){var y,rs=this.readyState,c=w[u];if(rs&&rs!="complete"&&rs!="loaded"){return}try{y=YAHOO.ywa.I13N.fireBeacon;w[u]=[];w[u].push=function(p){y([p])};y(c)}catch(e){}};var scr=d.getElementsByTagName(t)[0],par=scr.parentNode;par.insertBefore(s,scr)})(window,document,"script","https://s.yimg.com/wi/ytc.js","dotq");</script>
</head>
<body data-rsssl=1>

<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=10" />
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=51"></script>
<link rel="manifest" href="/manifest.json">
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
<script>
	  
	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'americanbankingnews.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			console.log(url);
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
	  
    OneSignal.push(["init", {
		  appId: "e990a3cc-a882-4055-92e5-f5bbd425d86e",
		  safari_web_id: 'web.onesignal.auto.66a57acb-1f7c-44c2-af57-20e68d9690d6', 
		  autoRegister: false,
		  autoResubscribe: true,
		  notifyButton: {
			enable: false /* Set to false to hide */
		  },
		 welcomeNotification: {
				"title": "Join Wall Street's Brightest Minds.",
				"message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
				 "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
			}
		},
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}

  </script>
<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-American Banking News', 'americanbankingnews.com', 'LON:CPG', 'Compass Group', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/compass-group-logo.png');</script>

<div class="page-wrap">
<header>
<div id="top-bar">
<div class="width-limiter">

<nav class="navigation"><ul id="menu-top-pages" class="menu"><li id="menu-item-5645782" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5645782"><a href="https://www.americanbankingnews.com/">Home</a></li>
<li id="menu-item-5636672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636672"><a href="https://www.americanbankingnews.com/about">About</a></li>
<li id="menu-item-5636674" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636674"><a href="https://www.americanbankingnews.com/daily-email-updates-basic">Email Newsletter</a></li>
<li id="menu-item-5636671" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636671"><a href="https://www.americanbankingnews.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-5636673" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636673"><a href="https://www.americanbankingnews.com/contact">Contact</a></li>
</ul></nav> <form id="searchform" action="https://www.americanbankingnews.com/" method="get">
<div id="search">
<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="Search" />
</div>
</form>

</div>

</div>

<div class="width-limiter add-padding">

<a class="logo-link" href="https://www.americanbankingnews.com"><img id="logo" src="/wp-content/uploads/2016/01/american-banking-and-market-news-logo-250.png" alt="American Banking News logo"></a>

<div id="AlternateHeaderUnit">
<iframe src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no"></iframe>
</div>

</div>

<div id="menu">
<div class="width-limiter" id="nav-main">

<nav class="navigation"><ul id="menu-categories" class="menu"><li id="menu-item-5637870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637870"><a href="https://www.americanbankingnews.com/category/market-news/analyst-articles-us">Analyst Ratings</a></li>
<li id="menu-item-5637876" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637876"><a href="https://www.americanbankingnews.com/category/market-news/dividend-articles">Dividends</a></li>
<li id="menu-item-5637877" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5637877"><a href="https://www.americanbankingnews.com/category/market-news/earnings-articles-single">Earnings</a>
<ul class="sub-menu">
<li id="menu-item-5645771" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645771"><a href="https://www.americanbankingnews.com/category/market-news/analyst-articles-us/analysts-eps-estimates">Estimates</a></li>
<li id="menu-item-5645772" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645772"><a href="https://www.americanbankingnews.com/category/market-news/guidance-articles">Guidance</a></li>
</ul>
</li>
<li id="menu-item-5645779" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645779"><a href="https://www.americanbankingnews.com/category/market-news/price-articles">Highs and Lows</a></li>
<li id="menu-item-5637879" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637879"><a href="https://www.americanbankingnews.com/category/market-news/ipo-articles">IPOS</a></li>
<li id="menu-item-5645780" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645780"><a href="https://www.americanbankingnews.com/category/market-news/options-articles">Options</a></li>
<li id="menu-item-5637880" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637880"><a href="https://www.americanbankingnews.com/category/market-news/sec-filing-articles">SEC Filings</a></li>
</ul></nav> </div>

</div>

</header>

<div class="width-limiter main-content">
<aside>
<div>
<iframe src="https://marketbeat.com/scripts/SidebarAdNewsSites.ashx" width="336" height="280" frameborder="no"></iframe>
<div class="ad336x280">
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div>

<div class="ad336x280">
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div>



<div class="sidebar-email">
<h3>Daily Ratings &amp; News for Compass Group</h3>
Complete the form below to receive the latest headlines and analysts' recommendations for Compass Group with our free daily email newsletter:<br />
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
<input type="hidden" id="Hidden1" name="RegistrationCode" value="American Banking News-Sidebar">
<input type="hidden" id="Hidden2" name="RegisterTicker" value="LON:CPG" /> <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
<div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
</form>
</div>

<div>
<a href="https://twitter.com/americanbanking" class="twitter-follow-button" data-show-count="false">Follow @AmericanBanking</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</div>

<div id="AmericanBankingNews_ROS_RightRail_1" class="text-center">
<script type="text/javascript">
		apntag.anq.push(function() {
			apntag.showTag('AmericanBankingNews_ROS_RightRail_1');
		});
	</script>
</div>


<br />
<div>
<h3>Recent Posts</h3>
<ul>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/bellway-lonbwy-pt-lowered-to-gbx-3080-at-hsbc.html">Bellway (LON:BWY) PT Lowered to GBX 3,080 at HSBC</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/berenberg-bank-trims-ascential-lonascl-target-price-to-gbx-240.html">Berenberg Bank Trims Ascential (LON:ASCL) Target Price to GBX 240</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/jefferies-financial-group-trims-centrica-loncna-target-price-to-gbx-50.html">Jefferies Financial Group Trims Centrica (LON:CNA) Target Price to GBX 50</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/bt-group-class-a-lonbt-a-given-new-gbx-190-price-target-at-goldman-sachs-group.html">BT Group &#8211; CLASS A (LON:BT.A) Given New GBX 190 Price Target at Goldman Sachs Group</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/berkeley-group-lonbkg-pt-lowered-to-gbx-5940.html">Berkeley Group (LON:BKG) PT Lowered to GBX 5,940</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/antofagasta-lonanto-lowered-to-underperform-at-royal-bank-of-canada.html">Antofagasta (LON:ANTO) Lowered to Underperform at Royal Bank of Canada</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/anglo-american-lonaal-stock-rating-lowered-by-royal-bank-of-canada.html">Anglo American (LON:AAL) Stock Rating Lowered by Royal Bank of Canada</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html">UBS Group Reaffirms Buy Rating for Compass Group (LON:CPG)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/barclays-lonbarc-given-buy-rating-at-berenberg-bank.html">Barclays (LON:BARC) Given &#8220;Buy&#8221; Rating at Berenberg Bank</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/cintas-ctas-investment-analysts-weekly-ratings-changes.html">Cintas (CTAS) &#8211; Investment Analysts&#8217; Weekly Ratings Changes</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/analysts-recent-ratings-changes-for-macys-m.html">Analysts&#8217; Recent Ratings Changes for Macy&#8217;s (M)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/weekly-analysts-ratings-updates-for-ingersoll-rand-ir.html">Weekly Analysts&#8217; Ratings Updates for Ingersoll-Rand (IR)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/recent-research-analysts-ratings-updates-for-tapestry-tpr.html">Recent Research Analysts&#8217; Ratings Updates for Tapestry (TPR)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/weekly-research-analysts-ratings-changes-for-peoples-united-financial-pbct.html">Weekly Research Analysts&#8217; Ratings Changes for People&#8217;s United Financial (PBCT)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/bok-financial-bokf-analysts-weekly-ratings-updates.html">BOK Financial (BOKF) &#8211; Analysts&#8217; Weekly Ratings Updates</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/recent-investment-analysts-ratings-updates-for-affiliated-managers-group-amg.html">Recent Investment Analysts&#8217; Ratings Updates for Affiliated Managers Group (AMG)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/research-analysts-recent-ratings-changes-for-everest-re-group-re.html">Research Analysts&#8217; Recent Ratings Changes for Everest Re Group (RE)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/research-analysts-weekly-ratings-changes-for-tal-education-group-tal.html">Research Analysts&#8217; Weekly Ratings Changes for TAL Education Group (TAL)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/pldt-phi-investment-analysts-recent-ratings-changes.html">PLDT (PHI) &#8211; Investment Analysts&#8217; Recent Ratings Changes</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2020/04/06/recent-investment-analysts-ratings-updates-for-suncor-energy-su.html">Recent Investment Analysts&#8217; Ratings Updates for Suncor Energy (SU)</a></li>
</ul>
</div>

</aside>

<main>
<article itemscope itemtype="http://schema.org/NewsArticle">
<link itemprop="mainEntityOfPage" href="https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html" />
<h1 itemprop="headline" class="page-title">UBS Group Reaffirms Buy Rating for Compass Group (LON:CPG)</h1>
<p class="postmeta">
Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.americanbankingnews.com/author/Matt" title="Posts by ABMN Staff" rel="author">ABMN Staff</a></span></span> on <span itemprop="datePublished dateModified" content="2020-04-06T05:24:51+0000">Apr 6th, 2020</span> // <a href="https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html#respond" class="comments-link">No Comments</a> </p>


<div class="entry" itemprop="articleBody">

<p><img src="/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/compass-group-logo.png" alt="Compass Group logo" title="Compass Group logo" class="companylogo" /><span>Compass Group (LON:CPG)</span>&#8216;s stock had its &#8220;buy&#8221; rating reissued by equities research analysts at UBS Group in a note issued to investors on Monday, <a href="http://investing.thisismoney.co.uk/broker-views/index/date/06-04-2020/" target="_blank">ThisIsMoney.Co.Uk</a> reports. They currently have a GBX 1,705 ($22.43) price objective on the stock, down from their prior price objective of GBX 2,225 ($29.27). UBS Group&#8217;s price target indicates a potential upside of 50.42% from the company&#8217;s current price.</p>
<p>A number of other equities analysts also recently weighed in on the stock. Citigroup dropped their price target on shares of Compass Group from GBX 2,200 ($28.94) to GBX 1,620 ($21.31) and set a &#8220;buy&#8221; rating on the stock in a research note on Tuesday, March 24th. Berenberg Bank dropped their price target on shares of Compass Group from GBX 2,200 ($28.94) to GBX 1,600 ($21.05) and set a &#8220;buy&#8221; rating on the stock in a research note on Monday, March 30th. JPMorgan Chase &#038; Co. decreased their price objective on shares of Compass Group from GBX 2,040 ($26.84) to GBX 1,920 ($25.26) and set an &#8220;overweight&#8221; rating for the company in a report on Tuesday, March 17th. Goldman Sachs Group upgraded shares of Compass Group to a &#8220;buy&#8221; rating and decreased their price objective for the stock from GBX 1,800 ($23.68) to GBX 1,600 ($21.05) in a report on Wednesday, March 18th. Finally, HSBC reiterated a &#8220;hold&#8221; rating on shares of Compass Group in a report on Wednesday, January 29th. One investment analyst has rated the stock with a sell rating, eight have given a hold rating and seven have given a buy rating to the company. The company currently has an average rating of &#8220;Hold&#8221; and a consensus price target of GBX 1,660.77 ($21.85).</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
<input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-American Banking News" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="LON:CPG" /> <label for="InPostRegistrationEmail">Get <b>Compass Group</b> alerts:</label>
<div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></div>
</form>
<div id="ShowSuggestionInPost"></div>
<p><a href='https://www.marketbeat.com/stocks/LON/CPG/price-target/' target='_blank'>LON CPG</a> opened at GBX 1,133.50 ($14.91) on Monday. Compass Group has a 1-year low of GBX 20.62 ($0.27) and a 1-year high of GBX 2,150 ($28.28). The company has a current ratio of 0.76, a quick ratio of 0.63 and a debt-to-equity ratio of 115.32. The company has a market capitalization of $17.47 billion and a PE ratio of 16.22. The firm&#8217;s fifty day simple moving average is GBX 1,510.48 and its 200-day simple moving average is GBX 1,843.42. </p>
<p>
<span style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px; width: 340px;">

<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9254111670"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>

</span>
In other news, insider John Bason purchased 1,212 shares of the firm&#8217;s stock in a transaction on Tuesday, March 3rd. The stock was bought at an average cost of GBX 1,729 ($22.74) per share, for a total transaction of £20,955.48 ($27,565.75). </p>
<p><strong>Compass Group Company Profile</strong></p>
<p>Compass Group PLC, through its subsidiaries, operates as a food and support services company in North America, Europe, and internationally. It serves business and industry; healthcare and senior living market; education; sports and leisure; and defense, offshore, and remote sectors. The company also offers support services, such as cleaning in hospitals; reception services at corporate headquarters; managing remote camps; grounds and facilities services at schools and universities; and others.</p>
<p>Featured Article: <a href='https://www.marketbeat.com/financial-terms/what-are-bollinger-bands/'>Bollinger Bands</a></p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/RatingsAndPriceTargetChart.ashx?Prefix=LON&#038;Symbol=CPG' alt='Analyst Recommendations for Compass Group (LON:CPG)' title='Analyst Recommendations for Compass Group (LON:CPG)' /></p>
<p></p>





<p style="clear:both"><strong>Receive News &amp; Ratings for Compass Group Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Compass Group and related companies with <a href="/daily-email-updates-basic/?symbol=LON:CPG&c=Compass+Group" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="American Banking News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="LON:CPG" /> <input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>

</div>



<div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
<link itemprop="url" href="/wp-content/timthumb/timthumb.php?w=300&h=300&zc=1&src=https://www.marketbeat.com/logos/compass-group-logo.png" />
<meta itemprop="width" content="300">
<meta itemprop="height" content="300">
</div>
<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.americanbankingnews.com/wp-content/uploads/2016/01/american-banking-and-market-news-logo-250.png">
<meta itemprop="width" content="251">
<meta itemprop="height" content="93">
</div>
<meta itemprop="name" content="American Banking News" />
<meta itemprop="url" content="https://americanbankingnews.com" />
</div>

</article>

<div id="AmericanBankingNews_ROS_BelowPost_1"></div><br><br>


<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx"></iframe>

<nav id="prevnext">

<a href="https://www.americanbankingnews.com/2020/04/06/cintas-ctas-investment-analysts-weekly-ratings-changes.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Cintas (CTAS) &#8211; Investment Analysts&#8217; Weekly Ratings Changes</p></div></a> <a href="https://www.americanbankingnews.com/2020/04/06/bt-group-class-a-lonbt-a-given-new-gbx-190-price-target-at-goldman-sachs-group.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>BT Group &#8211; CLASS A (LON:BT.A) Given New GBX 190 Price Target at Goldman Sachs Group</p></div></a>
</nav>

<div id="latest-news">
<h2>Latest News</h2>
<div class="latest-news-item">
<img src="/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/bellway-plc-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Bellway  PT Lowered to GBX 3,080 at HSBC" />
<br />

<a href="https://www.americanbankingnews.com/2020/04/06/bellway-lonbwy-pt-lowered-to-gbx-3080-at-hsbc.html" rel="bookmark">Bellway PT Lowered to GBX 3,080 at HSBC</a>
</div>
<div class="latest-news-item">
<img src="/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/centrica-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Jefferies Financial Group Trims Centrica  Target Price to GBX 50" />
<br />

<a href="https://www.americanbankingnews.com/2020/04/06/jefferies-financial-group-trims-centrica-loncna-target-price-to-gbx-50.html" rel="bookmark">Jefferies Financial Group Trims Centrica Target Price to GBX 50</a>
</div>
<div class="latest-news-item">
<img src="/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/bt-group-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="BT Group &#8211; CLASS A  Given New GBX 190 Price Target at Goldman Sachs Group" />
<br />

<a href="https://www.americanbankingnews.com/2020/04/06/bt-group-class-a-lonbt-a-given-new-gbx-190-price-target-at-goldman-sachs-group.html" rel="bookmark">BT Group &#8211; CLASS A Given New GBX 190 Price Target at Goldman Sachs Group</a>
</div>
<div class="latest-news-item">
<img src="/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/ascential-plc-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Berenberg Bank Trims Ascential  Target Price to GBX 240" />
<br />

<a href="https://www.americanbankingnews.com/2020/04/06/berenberg-bank-trims-ascential-lonascl-target-price-to-gbx-240.html" rel="bookmark">Berenberg Bank Trims Ascential Target Price to GBX 240</a>
</div>
<div class="latest-news-item">
<img src="/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/barclays-plc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Barclays  Given &#8220;Buy&#8221; Rating at Berenberg Bank" />
<br />

<a href="https://www.americanbankingnews.com/2020/04/06/barclays-lonbarc-given-buy-rating-at-berenberg-bank.html" rel="bookmark">Barclays Given &#8220;Buy&#8221; Rating at Berenberg Bank</a>
</div>
<div class="latest-news-item">
<img src="/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/antofagasta-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Antofagasta  Lowered to Underperform at Royal Bank of Canada" />
<br />

<a href="https://www.americanbankingnews.com/2020/04/06/antofagasta-lonanto-lowered-to-underperform-at-royal-bank-of-canada.html" rel="bookmark">Antofagasta Lowered to Underperform at Royal Bank of Canada</a>
</div>
</div>


<div class="comments-box">
<a name="comments" id="comments"></a>
<div id="respond">
<h3>Leave a Reply</h3>
<div class="cancel-comment-reply">
<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html#respond" style="display:none;">Click here to cancel reply.</a></small>
</div>
<form action="https://www.americanbankingnews.com/wp-comments-post.php" method="post" id="commentform">
<p>
<input type="text" name="author" class="txt" id="author" value="" size="22" tabindex="1" />
<label for="author">Name (Required) </label>
</p>
<p>
<input type="text" name="email" class="txt" id="email" value="" size="22" tabindex="2" />
<label for="email">Mail (will not be published) (Required) </label>
</p>
<p>
<input type="text" name="url" class="txt" id="url" value="" size="22" tabindex="3" />
<label for="url">Website</label>
</p>
<p><textarea autocomplete="nope" id="jdd35b8886" name="jdd35b8886" rows="10" cols="50" tabindex="4"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="nope" style="padding:0;clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script type="text/javascript">document.getElementById("comment").setAttribute( "id", "a06b583748eb8c37173a9d1d09c95469" );document.getElementById("jdd35b8886").setAttribute( "id", "comment" );</script></p>
<input name="submit" type="submit" id="submit" class="button" tabindex="5" value="Submit Comment" />
<input type="hidden" name="comment_post_ID" value="14070279" />
<input type='hidden' name='comment_post_ID' value='14070279' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</form>
</div>
</div> 

<br>
</main>

<div style="clear: both;"></div>
</div>

<footer class="full-width">
<div class="width-limiter">
<div id="footer-info" class="add-padding">
<nav class="navigation"><ul id="menu-categories-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637870"><a href="https://www.americanbankingnews.com/category/market-news/analyst-articles-us">Analyst Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637876"><a href="https://www.americanbankingnews.com/category/market-news/dividend-articles">Dividends</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5637877"><a href="https://www.americanbankingnews.com/category/market-news/earnings-articles-single">Earnings</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645771"><a href="https://www.americanbankingnews.com/category/market-news/analyst-articles-us/analysts-eps-estimates">Estimates</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645772"><a href="https://www.americanbankingnews.com/category/market-news/guidance-articles">Guidance</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645779"><a href="https://www.americanbankingnews.com/category/market-news/price-articles">Highs and Lows</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637879"><a href="https://www.americanbankingnews.com/category/market-news/ipo-articles">IPOS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645780"><a href="https://www.americanbankingnews.com/category/market-news/options-articles">Options</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637880"><a href="https://www.americanbankingnews.com/category/market-news/sec-filing-articles">SEC Filings</a></li>
</ul></nav> <span id="copyright">
&copy; 2006-2020 <a href="https://www.americanbankingnews.com">American Banking News</a>
</span>
</div>
</div>
</footer>
</div>
<script type='text/javascript' src='https://www.americanbankingnews.com/wp-includes/js/wp-embed.min.js?ver=5.0.8'></script>

<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
var pageTracker = _gat._getTracker("UA-3019647-13");
pageTracker._initData();
pageTracker._trackPageview();
</script>

<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>


<script type="text/javascript">
var sc_project=4951918; 
var sc_invisible=1; 
var sc_security="f1c0d9fb"; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>


<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html" target="_blank"><img src="/wp-content/themes/alambre/images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=UBS Group Reaffirms Buy Rating for Compass Group $LON:CPG https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html" target="_blank"><img src="/wp-content/themes/alambre/images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html" target="_blank"><img src="/wp-content/themes/alambre/images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=UBS Group Reaffirms Buy Rating for Compass Group $LON:CPG https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html" target="_blank"><img src="/wp-content/themes/alambre/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.americanbankingnews.com/2020/04/06/ubs-group-reaffirms-buy-rating-for-compass-group-loncpg.html&title=UBS Group Reaffirms Buy Rating for Compass Group (LON:CPG)" target="_blank"><img src="/wp-content/themes/alambre/images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
</div>


<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=50600241&PostDate=2020-4-6&type=a&id=1382722&domain=www.americanbankingnews.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>


<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>

</body>
</html>