<!doctype html>
<html lang="en">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="google-site-verification" content="XrACasD3S_CQnP2yJxxl5S9YRLFohKRD4XKOd35jL0Q" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">

<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link href="https://fonts.googleapis.com/css?family=Lato" rel="stylesheet">
<style>
		.green-span { 
color: #008217;
}


// styles start here
:root {
--text-black: #777;
}	</style>
<link rel="stylesheet" href="https://americanbankingnews.com/wp-content/themes/responsalambre/style.css?v=2020hijklmnopqrstuvwx1234567890123" type="text/css" media="screen">
<link href="https://www.americanbankingnews.com/feed" rel="alternate" title="American Banking News RSS Feed" type="application/rss+xml" />
<link href="https://www.americanbankingnews.com/feed/atom" rel="alternate" title="American Banking News Atom Feed" type="application/atom+xml" />
<link href="https://www.americanbankingnews.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="American Banking News &raquo; Anterix Inc. (NASDAQ:ATEX) Director Leslie B. Daniels Buys 4,000 Shares Comments Feed" href="https://www.americanbankingnews.com/2021/03/08/anterix-inc-nasdaqatex-director-leslie-b-daniels-buys-4000-shares.html/feed" />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.americanbankingnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.americanbankingnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.americanbankingnews.com/wp-json/wp/v2/posts/18823252" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.americanbankingnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.americanbankingnews.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Elaine R. Wedral Sells 3,000 Shares of Sensient Technologies Co. (NYSE:SXT) Stock' href='https://www.americanbankingnews.com/2021/03/08/elaine-r-wedral-sells-3000-shares-of-sensient-technologies-co-nysesxt-stock.html' />
<link rel='next' title='Insider Selling: Akamai Technologies, Inc. (NASDAQ:AKAM) EVP Sells 1,668 Shares of Stock' href='https://www.americanbankingnews.com/2021/03/08/insider-selling-akamai-technologies-inc-nasdaqakam-evp-sells-1668-shares-of-stock.html' />
<meta name="generator" content="WordPress 5.5.3" />
<link rel="canonical" href="https://www.americanbankingnews.com/2021/03/08/anterix-inc-nasdaqatex-director-leslie-b-daniels-buys-4000-shares.html" />
<link rel='shortlink' href='https://www.americanbankingnews.com/?p=18823252' />
<link rel="alternate" type="application/json+oembed" href="https://www.americanbankingnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.americanbankingnews.com%2F2021%2F03%2F08%2Fanterix-inc-nasdaqatex-director-leslie-b-daniels-buys-4000-shares.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.americanbankingnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.americanbankingnews.com%2F2021%2F03%2F08%2Fanterix-inc-nasdaqatex-director-leslie-b-daniels-buys-4000-shares.html&#038;format=xml" />
<link rel="amphtml" href="https://www.americanbankingnews.com/2021/03/08/anterix-inc-nasdaqatex-director-leslie-b-daniels-buys-4000-shares.html/amp" /><link rel="icon" href="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-market-news-icon-flame-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-market-news-icon-flame.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-market-news-icon-flame.png" />
<meta name="msapplication-TileImage" content="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-market-news-icon-flame.png" />

<title>Anterix Inc. (NASDAQ:ATEX) Director Leslie B. Daniels Buys 4,000 Shares - American Banking News</title>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="description" content="Anterix Inc. (NASDAQ:ATEX) Director Leslie B. Daniels purchased 4,000 shares of Anterix stock in a transaction dated Friday, March 5th. The shares were purchased at an average price of $41.00 per share, with a total value of $164,000.00. Following the completion of the acquisition, the director now owns 28,072 shares in the company, valued at [&hellip;]" />
<meta name="author" content="ABMN Staff">
<meta name="news_keywords" content="Anterix,NASDAQ:ATEX,ATEX,Computer and Technology,Insider Trading, Insider Trades, Stocks" />
<meta name="keywords" content="Anterix,NASDAQ:ATEX,ATEX,Computer and Technology,Insider Trading, Insider Trades, Stocks" />
<meta name="ticker" content="NASDAQ:ATEX" />
<meta name="contentType" content="article">

<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="Anterix Inc. (NASDAQ:ATEX) Director Leslie B. Daniels Buys 4,000 Shares" />
<meta name="twitter:description" content="Anterix Inc. (NASDAQ:ATEX) Director Leslie B. Daniels purchased 4,000 shares of Anterix stock in a transaction dated Friday, March 5th. The shares were purchased at an average price of $41.00 per share, with a total value of $164,000.00. Following the completion of the acquisition, the director now owns 28,072 shares in the company, valued at [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/anterix-inc-logo.png" />

<meta property="og:title" content="Anterix Inc. (NASDAQ:ATEX) Director Leslie B. Daniels Buys 4,000 Shares" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.americanbankingnews.com/2021/03/08/anterix-inc-nasdaqatex-director-leslie-b-daniels-buys-4000-shares.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/anterix-inc-logo.png" />
<meta property="og:description" content="Anterix Inc. (NASDAQ:ATEX) Director Leslie B. Daniels purchased 4,000 shares of Anterix stock in a transaction dated Friday, March 5th. The shares were purchased at an average price of $41.00 per share, with a total value of $164,000.00. Following the completion of the acquisition, the director now owns 28,072 shares in the company, valued at [&hellip;]" />
<meta property="og:site_name" content="American Banking News" />
<meta property="og:locale" content="en_US" />

<meta property="article:published_time" content="2021-03-08T18:06:41+0000" />
<meta property="article:modified_time" content="2021-03-08T18:06:41+0000" />
<meta property="article:tag" content="NASDAQ:ATEX" />
<meta property="article:tag" content="Anterix,NASDAQ:ATEX,ATEX,Computer and Technology,Insider Trading, Insider Trades, Stocks" />
<meta property="article:section" content="Market News" />


<script type='text/javascript'>var PopupAdChannel=''; </script>
<link rel="manifest" href="/manifest.json">
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
<script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'americanbankingnews.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "e990a3cc-a882-4055-92e5-f5bbd425d86e",
      safari_web_id: 'web.onesignal.auto.66a57acb-1f7c-44c2-af57-20e68d9690d6', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}  </script>
<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>

<script type="application/javascript">(function(w,d,t,r,u){w[u]=w[u]||[];w[u].push({'projectId':'10000','properties':{'pixelId':'423827'}});var s=d.createElement(t);s.src=r;s.async=true;s.onload=s.onreadystatechange=function(){var y,rs=this.readyState,c=w[u];if(rs&&rs!="complete"&&rs!="loaded"){return}try{y=YAHOO.ywa.I13N.fireBeacon;w[u]=[];w[u].push=function(p){y([p])};y(c)}catch(e){}};var scr=d.getElementsByTagName(t)[0],par=scr.parentNode;par.insertBefore(s,scr)})(window,document,"script","https://s.yimg.com/wi/ytc.js","dotq");</script>
</head>
<body data-rsssl=1>
<div id="wrap">

<script type='text/javascript'> var ShowInsiderTradesPopupFirst = true;</script><link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11" />
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>
<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-American Banking News', 'americanbankingnews.com', 'NASDAQ:ATEX', 'Anterix', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/anterix-inc-logo.png');</script>

<header>
<div class="width-limiter background-light" id='top-menu'>
<div style='color:#222;text-align:right;'>
<nav class="navigation top-menu"><ul id="menu-top-pages" class="menu"><li id="menu-item-5645782" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5645782"><a href="https://www.americanbankingnews.com/">Home</a></li>
<li id="menu-item-5636672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636672"><a href="https://www.americanbankingnews.com/about">About</a></li>
<li id="menu-item-5636674" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636674"><a href="https://www.americanbankingnews.com/daily-email-updates-basic">Newsletter</a></li>
<li id="menu-item-5636671" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636671"><a href="https://www.americanbankingnews.com/privacy-policy">Privacy</a></li>
<li id="menu-item-5636673" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636673"><a href="https://www.americanbankingnews.com/contact">Contact</a></li>
</ul></nav> </div>
</div>
<div class="width-limiter top-mobile-menu" id='mobile-logo-bar'>
<label for="nav-trigger" style="display:inline-block; width:30vw; color:#12424d;vertical-align:middle;">&#9776;</label>
<a style='vertical-align:middle;width:33vw;display:inline-block;text-align:center;padding:5px;' href="https://www.americanbankingnews.com"><img style='max-height: 60px;' src="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-and-market-news-logo-2020-gradient-04.png" alt="American Banking and Market News logo"></a>
</div>
<div class="width-limiter" style="min-height: 5px;" id='mobile-menu-bar'>
<input type="checkbox" id="nav-trigger" class="navOpen" />
<div class="mobile-nav nice-scroll">
<nav class="mobile-menu"><ul id="menu-categories" class="menu"><li id="menu-item-5637870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637870"><a href="https://www.americanbankingnews.com/category/market-news/analyst-articles-us">Analyst Ratings</a></li>
<li id="menu-item-5637876" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637876"><a href="https://www.americanbankingnews.com/category/market-news/dividend-articles">Dividends</a></li>
<li id="menu-item-5637877" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5637877"><a href="https://www.americanbankingnews.com/category/market-news/earnings-articles-single">Earnings</a>
<ul class="sub-menu">
<li id="menu-item-5645772" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645772"><a href="https://www.americanbankingnews.com/category/market-news/guidance-articles">Guidance</a></li>
</ul>
</li>
<li id="menu-item-5645779" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645779"><a href="https://www.americanbankingnews.com/category/market-news/price-articles">Highs and Lows</a></li>
<li id="menu-item-5637879" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637879"><a href="https://www.americanbankingnews.com/category/market-news/ipo-articles">IPOS</a></li>
<li id="menu-item-5645780" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645780"><a href="https://www.americanbankingnews.com/category/market-news/options-articles">Options</a></li>
<li id="menu-item-5637880" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637880"><a href="https://www.americanbankingnews.com/category/market-news/sec-filing-articles">SEC Filings</a></li>
</ul></nav> <nav class="mobile-menu"><ul id="menu-top-pages-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5645782"><a href="https://www.americanbankingnews.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636672"><a href="https://www.americanbankingnews.com/about">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636674"><a href="https://www.americanbankingnews.com/daily-email-updates-basic">Newsletter</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636671"><a href="https://www.americanbankingnews.com/privacy-policy">Privacy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636673"><a href="https://www.americanbankingnews.com/contact">Contact</a></li>
</ul></nav>
<form class="mobile-search" id="mobileSearchForm" action="https://www.americanbankingnews.com/" method="get">
<div id="search">
<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
<div>
</div>
</div>

</div>
<div class="width-limiter add-padding flex-container">
<a class="logo-link flex-logo" href="https://www.americanbankingnews.com"><img id="logo" src="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-and-market-news-logo-2020-gradient-04.png" alt="American Banking and Market News logo"></a>

<div id="AlternateHeaderUnit" class="flex-header-ad">
<iframe class="large-show" src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no" style="overflow:hidden;"></iframe>
<iframe class="small-show" src="https://marketbeat.com/scripts/SidebarAdNewsSites.ashx" width="336" height="280" frameborder="no" scrolling="no" style="overflow:hidden;margin:0 auto;"></iframe>
</div>

</div> 
<div id="menu">
<div class="width-limiter flex-container" id="nav-main">

<div class="flex-nav">
<nav class="navigation"><ul id="menu-categories-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637870"><a href="https://www.americanbankingnews.com/category/market-news/analyst-articles-us">Analyst Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637876"><a href="https://www.americanbankingnews.com/category/market-news/dividend-articles">Dividends</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5637877"><a href="https://www.americanbankingnews.com/category/market-news/earnings-articles-single">Earnings</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645772"><a href="https://www.americanbankingnews.com/category/market-news/guidance-articles">Guidance</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645779"><a href="https://www.americanbankingnews.com/category/market-news/price-articles">Highs and Lows</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637879"><a href="https://www.americanbankingnews.com/category/market-news/ipo-articles">IPOS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645780"><a href="https://www.americanbankingnews.com/category/market-news/options-articles">Options</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637880"><a href="https://www.americanbankingnews.com/category/market-news/sec-filing-articles">SEC Filings</a></li>
</ul></nav>
</div>
<form class="flex-search" id="searchform" action="https://www.americanbankingnews.com/" method="get">
<div id="search">
<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
</div> 
</div> 
</header> 
<div class="width-limiter main-content flex-container">
<main class="flex-main">
<article itemscope itemtype="http://schema.org/NewsArticle">
<link itemprop="mainEntityOfPage" href="https://www.americanbankingnews.com/2021/03/08/anterix-inc-nasdaqatex-director-leslie-b-daniels-buys-4000-shares.html" />
<h1 itemprop="headline" class="page-title">Anterix Inc. (NASDAQ:ATEX) Director Leslie B. Daniels Buys 4,000 Shares</h1>
<p class="postmeta">
Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.americanbankingnews.com/author/Matt" title="Posts by ABMN Staff" rel="author">ABMN Staff</a></span></span> on <span itemprop="datePublished dateModified" content="2021-03-08T18:06:41+0000">Mar 8th, 2021</span>
</p>
<br>
<div style="float:left; width:72px;">
<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-text="Anterix Inc. (NASDAQ:ATEX) Director Leslie B. Daniels Buys 4,000 Shares" data-via="RatingsNetwork">Tweet</a><script type="text/javascript" src="https://platform.twitter.com/widgets.js"></script>
</div>
<div style="float:left; width:85px;">
<iframe src="https://www.facebook.com/plugins/share_button.php?href=https://www.americanbankingnews.com/2021/03/08/anterix-inc-nasdaqatex-director-leslie-b-daniels-buys-4000-shares.html&layout=button_count&size=small&mobile_iframe=true&appId=129801551471&width=87&height=20" width="87" height="20" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>
</div>
<div style="float:left; width:76px;">
<script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
<script type="IN/Share" data-counter="right"></script>
</div>
<div style="float:left;width:112px">
<a href="https://api.stocktwits.com/widgets/share" id="stocktwits-share-button" data-text="Anterix Inc. (NASDAQ:ATEX) Director Leslie B. Daniels Buys 4,000 Shares $ATEX https://www.americanbankingnews.com/?p=18823252"><img src="https://api.stocktwits.com/assets/widget/stocktwits_share.png" alt="Share on StockTwits" /></a><script src="https://api.stocktwits.com/addon/button/share.min.js"></script>
</div>
<div style="clear:both"></div>

<div class="entry" itemprop="articleBody">

<iframe src="https://www.marketbeat.com/scripts/TextAdNewsSites.ashx?color=2f6f85" frameborder=no width="100%" height="35" scrolling="no"></iframe>
<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/anterix-inc-logo.png" alt="Anterix logo" title="Anterix logo" class="companylogo" />Anterix Inc. (NASDAQ:ATEX) Director Leslie B. Daniels purchased 4,000 shares of Anterix stock in a transaction dated Friday, March 5th. The shares were purchased at an average price of $41.00 per share, with a total value of $164,000.00. Following the completion of the acquisition, the director now owns 28,072 shares in the company, valued at $1,150,952. The transaction was disclosed in a filing with the Securities &amp; Exchange Commission, which can be accessed through <a href="https://www.sec.gov/Archives/edgar/data/1052559/000120919121018689/xslF345X03/doc4.xml" target='_blank' rel="noopener noreferrer">this link</a>. </p>
<p><a href='https://www.pricetargets.com/NASDAQ/ATEX/' target='_blank' rel="noopener noreferrer">NASDAQ:ATEX</a> traded up $0.86 during midday trading on Monday, reaching $43.87. The stock had a trading volume of 219,649 shares, compared to its average volume of 254,905. Anterix Inc. has a 1-year low of $27.26 and a 1-year high of $57.75. The firm&#8217;s fifty day simple moving average is $39.78 and its 200-day simple moving average is $36.62. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
<input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-American Banking News" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:ATEX" /> <label for="InPostRegistrationEmail">Get <b>Anterix</b> alerts:</label>
<div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></div>
</form>
<div id="ShowSuggestionInPost"></div>
<p>Anterix (NASDAQ:ATEX) last announced its earnings results on Sunday, February 7th. The company reported ($0.69) earnings per share for the quarter, beating the consensus estimate of ($0.77) by $0.08. Anterix had a negative return on equity of 21.60% and a negative net margin of 4,358.98%. As a group, analysts anticipate that Anterix Inc. will post -3.01 EPS for the current fiscal year. </p>
<p>
<div class="in-article-ad" class="width:340px;">
<iframe src="https://marketbeat.com/scripts/336x280AdNewsSites.ashx" width="336" height="280" frameborder="no"></iframe>
</div>
Several institutional investors and hedge funds have recently bought and sold shares of the company. Point72 Asset Management L.P. increased its position in Anterix by 68.5% during the third quarter. Point72 Asset Management L.P. now owns 33,200 shares of the company&#8217;s stock worth $1,086,000 after acquiring an additional 13,500 shares during the period. SG Americas Securities LLC grew its position in Anterix by 4.1% in the 3rd quarter. SG Americas Securities LLC now owns 17,107 shares of the company&#8217;s stock worth $560,000 after purchasing an additional 672 shares during the last quarter. Gabelli Funds LLC bought a new position in shares of Anterix during the 3rd quarter worth about $2,188,000. Aigen Investment Management LP increased its holdings in shares of Anterix by 106.5% during the 3rd quarter. Aigen Investment Management LP now owns 10,036 shares of the company&#8217;s stock worth $328,000 after purchasing an additional 5,176 shares during the period. Finally, Steward Partners Investment Advisory LLC lifted its stake in shares of Anterix by 66.7% in the third quarter. Steward Partners Investment Advisory LLC now owns 1,250 shares of the company&#8217;s stock valued at $41,000 after buying an additional 500 shares during the period. 91.23% of the stock is owned by institutional investors. </p>
<p>ATEX has been the subject of several research reports. <a style='font-weight:bold' href='https://www.zacks.com/registration/premium/login/?adid=AMERBMN_CONTENT_ZER'>Zacks Investment Research</a> lowered Anterix from a &#8220;hold&#8221; rating to a &#8220;sell&#8221; rating in a report on Friday, January 29th. Morgan Stanley reduced their price objective on shares of Anterix from $50.00 to $48.00 and set an &#8220;equal weight&#8221; rating for the company in a research note on Wednesday, January 27th. Finally, JPMorgan Chase &#038; Co. raised shares of Anterix from a &#8220;neutral&#8221; rating to an &#8220;overweight&#8221; rating and increased their target price for the stock from $40.00 to $50.00 in a research report on Wednesday, February 17th. One analyst has rated the stock with a sell rating, one has assigned a hold rating and three have issued a buy rating to the stock. The company has a consensus rating of &#8220;Hold&#8221; and a consensus target price of $67.40.</p>
<p><strong>About Anterix</strong></p>
<p>Anterix Inc operates as a wireless communications company. The company focuses on commercializing its spectrum assets to enable the targeted utility and critical infrastructure customers to deploy private broadband networks, technologies, and solutions. It holds licensed spectrum in the 900 MHz band with nationwide coverage throughout the United States, Hawaii, Alaska, and Puerto Rico.</p>
<p>Recommended Story: <a href='https://www.marketbeat.com/financial-terms/systematic-risk-investors/'>Can systematic risk be avoided?</a></p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/InsiderTradesChart.ashx?Prefix=NASDAQ&#038;Symbol=ATEX' alt='Insider Buying and Selling by Quarter for Anterix (NASDAQ:ATEX)' title='Insider Buying and Selling by Quarter for Anterix (NASDAQ:ATEX)' /></p>
<p></p>





<p style="clear:both"><strong>Receive News &amp; Ratings for Anterix Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Anterix and related companies with <a href="/daily-email-updates-basic/?symbol=NASDAQ:ATEX&c=Anterix" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="American Banking News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:ATEX" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>

</div> 


<div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=300&h=300&zc=1&src=https://www.marketbeat.com/logos/anterix-inc-logo.png" />
<meta itemprop="width" content="300">
<meta itemprop="height" content="300">
</div>
<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-and-market-news-logo-2020-gradient-04.png">
<meta itemprop="width" content="415">
<meta itemprop="height" content="151">
</div>
<meta itemprop="name" content="American Banking News" />
<meta itemprop="url" content="https://americanbankingnews.com" />
</div>

</article>

<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx"></iframe>


<nav id="prevnext">
<a href="https://www.americanbankingnews.com/2021/03/08/elaine-r-wedral-sells-3000-shares-of-sensient-technologies-co-nysesxt-stock.html" rel="prev"><div class="previous"><h4>&laquo; PREVIOUS</h4><p>Elaine R. Wedral Sells 3,000 Shares of Sensient Technologies Co. (NYSE:SXT) Stock</p></div></a> <a href="https://www.americanbankingnews.com/2021/03/08/insider-selling-akamai-technologies-inc-nasdaqakam-evp-sells-1668-shares-of-stock.html" rel="next"><div class="next"><h4>NEXT &raquo;</h4><p>Insider Selling: Akamai Technologies, Inc. (NASDAQ:AKAM) EVP Sells 1,668 Shares of Stock</p></div></a>
</nav>
<div id="latest-news">
<h2>You might be interested in:</h2>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/036_johnsonandjohnson.png&amp;h=45&amp;w=95&amp;zc=2" width="65" alt="Wisconsin Capital Management LLC Buys 8,495 Shares of Johnson &#038; Johnson " />
</div></div>

<a href="https://www.americanbankingnews.com/2021/03/08/wisconsin-capital-management-llc-buys-8495-shares-of-johnson-johnson-nysejnj.html" rel="bookmark">Wisconsin Capital Management LLC Buys 8,495 Shares of Johnson &#038; Johnson </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/036_johnsonandjohnson.png&amp;h=45&amp;w=95&amp;zc=2" width="65" alt="Johnson &#038; Johnson  Shares Sold by Wealth Enhancement Advisory Services LLC" />
</div></div>

<a href="https://www.americanbankingnews.com/2021/03/08/johnson-johnson-nysejnj-shares-sold-by-wealth-enhancement-advisory-services-llc.html" rel="bookmark">Johnson &#038; Johnson Shares Sold by Wealth Enhancement Advisory Services LLC</a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/lkq-co-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" alt="Mackenzie Financial Corp Has $7.44 Million Stock Position in LKQ Co. " />
</div></div>

<a href="https://www.americanbankingnews.com/2021/03/08/mackenzie-financial-corp-has-7-44-million-stock-position-in-lkq-co-nasdaqlkq.html" rel="bookmark">Mackenzie Financial Corp Has $7.44 Million Stock Position in LKQ Co. </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/036_johnsonandjohnson.png&amp;h=45&amp;w=95&amp;zc=2" width="65" alt="Barrett Asset Management LLC Has $43.43 Million Stock Position in Johnson &#038; Johnson " />
</div></div>

<a href="https://www.americanbankingnews.com/2021/03/08/barrett-asset-management-llc-has-43-43-million-stock-position-in-johnson-johnson-nysejnj.html" rel="bookmark">Barrett Asset Management LLC Has $43.43 Million Stock Position in Johnson &#038; Johnson </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks3.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" alt="Mackenzie Financial Corp Invests $7.42 Million in Vontier Co. " />
</div></div>

<a href="https://www.americanbankingnews.com/2021/03/08/mackenzie-financial-corp-invests-7-42-million-in-vontier-co-nysevnt.html" rel="bookmark">Mackenzie Financial Corp Invests $7.42 Million in Vontier Co. </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/striker-exploration-corp-logo.png&amp;h=45&amp;w=95&amp;zc=2" width="65" alt="203,425 Shares in Skechers U.S.A., Inc.  Acquired by Mackenzie Financial Corp" />
</div></div>

<a href="https://www.americanbankingnews.com/2021/03/08/203425-shares-in-skechers-u-s-a-inc-nyseskx-acquired-by-mackenzie-financial-corp.html" rel="bookmark">203,425 Shares in Skechers U.S.A., Inc. Acquired by Mackenzie Financial Corp</a>
</div>
</div>

<br>
</main> 
<aside class="flex-sidebar">
<div class="flex-container">
<div class="sidebar-section">
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no"></iframe><br><br>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>

<br><br>


<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>

<br><br>

</div>
<div class="sidebar-section">


<div class="sidebar-email">
<h3>Daily Ratings &amp; News for Anterix</h3>
Complete the form below to receive the latest headlines and analysts' recommendations for Anterix with our free daily email newsletter:<br />
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
<input type="hidden" id="Hidden1" name="RegistrationCode" value="American Banking News-Sidebar">
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:ATEX" /> <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
<div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
</form>
</div>



<br />
<div>
<h3>Recent News</h3>
<ul>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/wisconsin-capital-management-llc-buys-8495-shares-of-johnson-johnson-nysejnj.html">Wisconsin Capital Management LLC Buys 8,495 Shares of Johnson &#038; Johnson (NYSE:JNJ)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/johnson-johnson-nysejnj-shares-sold-by-wealth-enhancement-advisory-services-llc.html">Johnson &#038; Johnson (NYSE:JNJ) Shares Sold by Wealth Enhancement Advisory Services LLC</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/mackenzie-financial-corp-has-7-44-million-stock-position-in-lkq-co-nasdaqlkq.html">Mackenzie Financial Corp Has $7.44 Million Stock Position in LKQ Co. (NASDAQ:LKQ)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/barrett-asset-management-llc-has-43-43-million-stock-position-in-johnson-johnson-nysejnj.html">Barrett Asset Management LLC Has $43.43 Million Stock Position in Johnson &#038; Johnson (NYSE:JNJ)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/mackenzie-financial-corp-invests-7-42-million-in-vontier-co-nysevnt.html">Mackenzie Financial Corp Invests $7.42 Million in Vontier Co. (NYSE:VNT)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/203425-shares-in-skechers-u-s-a-inc-nyseskx-acquired-by-mackenzie-financial-corp.html">203,425 Shares in Skechers U.S.A., Inc. (NYSE:SKX) Acquired by Mackenzie Financial Corp</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/mackenzie-financial-corp-has-7-20-million-stock-holdings-in-ebay-inc-nasdaqebay.html">Mackenzie Financial Corp Has $7.20 Million Stock Holdings in eBay Inc. (NASDAQ:EBAY)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/mackenzie-financial-corp-boosts-holdings-in-extra-space-storage-inc-nyseexr.html">Mackenzie Financial Corp Boosts Holdings in Extra Space Storage Inc. (NYSE:EXR)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/south-state-corp-lowers-position-in-johnson-johnson-nysejnj.html">South State CORP. Lowers Position in Johnson &#038; Johnson (NYSE:JNJ)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/fortune-brands-home-security-inc-nysefbhs-position-increased-by-mackenzie-financial-corp.html">Fortune Brands Home &#038; Security, Inc. (NYSE:FBHS) Position Increased by Mackenzie Financial Corp</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/davidson-investment-advisors-cuts-holdings-in-johnson-johnson-nysejnj.html">Davidson Investment Advisors Cuts Holdings in Johnson &#038; Johnson (NYSE:JNJ)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/mackenzie-financial-corp-boosts-stake-in-hca-healthcare-inc-nysehca.html">Mackenzie Financial Corp Boosts Stake in HCA Healthcare, Inc. (NYSE:HCA)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/mackenzie-financial-corp-raises-stake-in-church-dwight-co-inc-nysechd.html">Mackenzie Financial Corp Raises Stake in Church &#038; Dwight Co., Inc. (NYSE:CHD)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/mackenzie-financial-corp-trims-stake-in-robert-half-international-inc-nyserhi.html">Mackenzie Financial Corp Trims Stake in Robert Half International Inc. (NYSE:RHI)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/insider-selling-alpine-immune-sciences-inc-nasdaqalpn-ceo-sells-10000-shares-of-stock.html">Insider Selling: Alpine Immune Sciences, Inc. (NASDAQ:ALPN) CEO Sells 10,000 Shares of Stock</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/douglas-n-comings-sells-2000-shares-of-brinker-international-inc-nyseeat-stock.html">Douglas N. Comings Sells 2,000 Shares of Brinker International, Inc. (NYSE:EAT) Stock</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/e-j-wunsch-purchases-7500-shares-of-the-wendys-company-nasdaqwen-stock.html">E.J. Wunsch Purchases 7,500 Shares of The Wendy&#8217;s Company (NASDAQ:WEN) Stock</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/insider-selling-akamai-technologies-inc-nasdaqakam-evp-sells-1668-shares-of-stock.html">Insider Selling: Akamai Technologies, Inc. (NASDAQ:AKAM) EVP Sells 1,668 Shares of Stock</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/boise-cascade-nysebcc-vp-sells-156768-80-in-stock.html">Boise Cascade (NYSE:BCC) VP Sells $156,768.80 in Stock</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2021/03/08/luke-alverson-sells-1200-shares-of-csw-industrials-inc-nasdaqcswi-stock.html">Luke Alverson Sells 1,200 Shares of CSW Industrials, Inc. (NASDAQ:CSWI) Stock</a></li>
</ul>
</div>
</div>
</div>

</aside>
<div style="clear: both;"></div>
</div> 
<footer class="full-width">
<div class="width-limiter flex-container">
<div id="footer-info" class="add-padding flex-nav">
<nav class="navigation"><ul id="menu-categories-2" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637870"><a href="https://www.americanbankingnews.com/category/market-news/analyst-articles-us">Analyst Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637876"><a href="https://www.americanbankingnews.com/category/market-news/dividend-articles">Dividends</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5637877"><a href="https://www.americanbankingnews.com/category/market-news/earnings-articles-single">Earnings</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645772"><a href="https://www.americanbankingnews.com/category/market-news/guidance-articles">Guidance</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645779"><a href="https://www.americanbankingnews.com/category/market-news/price-articles">Highs and Lows</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637879"><a href="https://www.americanbankingnews.com/category/market-news/ipo-articles">IPOS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645780"><a href="https://www.americanbankingnews.com/category/market-news/options-articles">Options</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637880"><a href="https://www.americanbankingnews.com/category/market-news/sec-filing-articles">SEC Filings</a></li>
</ul></nav> </div>
<span id="copyright" class="add-padding flex-copyright">
&copy; 2018-2021 <a href="https://www.americanbankingnews.com">American Banking News</a>
</span>
</div>
</footer>
<script type='text/javascript' src='https://www.americanbankingnews.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>
</div>

<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>


<script type="text/javascript">
var sc_project=4951918; 
var sc_invisible=1; 
var sc_security="f1c0d9fb"; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>


<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=70283257&PostDate=2021-3-8&type=i&id=434124&domain=www.americanbankingnews.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>

</body>
</html>
