<!doctype html>
<html lang="en">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="theme-color" content="#75411d" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">

<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link rel="preconnect" href="https://fonts.gstatic.com">
<link href="https://fonts.googleapis.com/css2?family=Lato&family=Roboto+Condensed&display=swap" rel="stylesheet">
<style>

:root {
  --header-background: #ffffff;
  --button-background: #75411d;
  --button-background-2: #a86528;
  --button-hover-background: #75411d;
  --button-hover-background-2: #a86528;
  --button-text-color: #fff;
  --link-color: #24778d;
  --link-hover-color: #267e94;
  --link-text-decoration: none; /* text field */
  --hover-link-text-decoration: underline; /* text field */
  --menu-background: #0e353e;
  --menu-background-2: #164f5e;
  --menu-text-color: #fff;
  --menu-active-hover-background: #24778c;
  --menu-active-hover-text-color: #fff;
  --top-menu-background: #eff2f5;
  --top-menu-link-color: #24778d;
  --top-menu-link-hover-color: #164f5e;
  --accent-color: #75411d;
  --accent-color-2: #a86528;
  --sidebar-h3-color: #24778d;
  --light-gray-color:#eff2f4;
  --light-gray-link-color:#eff2f4;
  --light-gray-link-hover-color:#eff2f4;
  --list-item-bottom-border: solid 1px #eff2f4;
  --border-radius: none;
  --border-radius-small-items: underline;
  --H1-font: bold 2em/1.3 "Lato",sans-serif;
  --H2-font:  bold 1.3em/1.3 "Lato",sans-serif;
  --H3-font:  bold uppercase 1.1em/1.3 "Roboto Condensed",sans-serif;
  --body-font: 15px "Lato",sans-serif;
  --menu-font: 1em "Roboto Condensed", sans-serif;
  --box-shadow: 0 0 8px 0 rgb(0 0 0 / 10%), 1px 4px 3px 0 rgb(0 0 0 / 10%); 
  --body-background: #0e353f;
  --body-background-2: #164f5e;
  --body-font-color: #000;

}


body {
	font: var(--body-font);
    background: var(--body-background);
	color: var(--body-font-color);
	 
		
	background: -moz-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -webkit-gradient(left top,left bottom,color-stop(0%, var(--body-background)),color-stop(100%, var(--body-background-2)));
    background: -webkit-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -o-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -ms-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: linear-gradient(to bottom, var(--body-background) 0%, var(--body-background-2) 100%);
		
    background-attachment: fixed;
    background-size: cover;
}

</style>
<link rel="stylesheet" href="https://www.americanbankingnews.com/wp-content/themes/responsalambre/style.css?v=2021abcdefghij" type="text/css" media="screen">
<link href="https://www.americanbankingnews.com/feed" rel="alternate" title="American Banking News RSS Feed" type="application/rss+xml" />
<link href="https://www.americanbankingnews.com/feed/atom" rel="alternate" title="American Banking News Atom Feed" type="application/atom+xml" />
<link href="https://www.americanbankingnews.com/xmlrpc.php" rel="pingback" />
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="American Banking News &raquo; Mitsubishi UFJ Trust &#038; Banking Corp Sells 28,626 Shares of eBay Inc. (NASDAQ:EBAY) Comments Feed" href="https://www.americanbankingnews.com/2022/11/14/mitsubishi-ufj-trust-banking-corp-sells-28626-shares-of-ebay-inc-nasdaqebay.html/feed" />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.americanbankingnews.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel="https://api.w.org/" href="https://www.americanbankingnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.americanbankingnews.com/wp-json/wp/v2/posts/26562347" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.americanbankingnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.americanbankingnews.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.3" />
<link rel="canonical" href="https://www.americanbankingnews.com/2022/11/14/mitsubishi-ufj-trust-banking-corp-sells-28626-shares-of-ebay-inc-nasdaqebay.html" />
<link rel='shortlink' href='https://www.americanbankingnews.com/?p=26562347' />
<link rel="alternate" type="application/json+oembed" href="https://www.americanbankingnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.americanbankingnews.com%2F2022%2F11%2F14%2Fmitsubishi-ufj-trust-banking-corp-sells-28626-shares-of-ebay-inc-nasdaqebay.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.americanbankingnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.americanbankingnews.com%2F2022%2F11%2F14%2Fmitsubishi-ufj-trust-banking-corp-sells-28626-shares-of-ebay-inc-nasdaqebay.html&#038;format=xml" />
<link rel="manifest" href="https://www.americanbankingnews.com/manifest.json"><link rel="icon" href="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-market-news-icon-flame-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-market-news-icon-flame.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-market-news-icon-flame.png" />
<meta name="msapplication-TileImage" content="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-market-news-icon-flame.png" />
<style type="text/css" id="wp-custom-css">
			#menu .navigation li a{letter-spacing:-0.5px;}		</style>

<title>Mitsubishi UFJ Trust &#038; Banking Corp Sells 28,626 Shares of eBay Inc. (NASDAQ:EBAY) - American Banking News</title>
<meta name="description" content="Read Mitsubishi UFJ Trust &#038; Banking Corp Sells 28,626 Shares of eBay Inc. (NASDAQ:EBAY) at American Banking News" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="description" content="Mitsubishi UFJ Trust &#038; Banking Corp lessened its position in shares of eBay Inc. (NASDAQ:EBAY &#8211; Get Rating) by 3.2% in the second quarter, according to the company in its most recent disclosure with the Securities &amp; Exchange Commission. The firm owned 872,406 shares of the e-commerce company&#8217;s stock after selling 28,626 shares during the [&hellip;]" />
<meta name="author" content="ABMN Staff">
<meta name="news_keywords" content="eBay,NASDAQ:EBAY,EBAY,Retail/Wholesale,27864210,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="keywords" content="eBay,NASDAQ:EBAY,EBAY,Retail/Wholesale,27864210,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="ticker" content="NASDAQ:EBAY" />
<meta name="contentType" content="article">

<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@MarketBeatCom" />
<meta name="twitter:title" content="Mitsubishi UFJ Trust &#038; Banking Corp Sells 28,626 Shares of eBay Inc. (NASDAQ:EBAY)" />
<meta name="twitter:description" content="Mitsubishi UFJ Trust &#038; Banking Corp lessened its position in shares of eBay Inc. (NASDAQ:EBAY &#8211; Get Rating) by 3.2% in the second quarter, according to the company in its most recent disclosure with the Securities &amp; Exchange Commission. The firm owned 872,406 shares of the e-commerce company&#8217;s stock after selling 28,626 shares during the [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/ebay-inc-logo.png&amp;w=240&amp;h=240&amp;zc=2" />

<meta property="og:title" content="Mitsubishi UFJ Trust &#038; Banking Corp Sells 28,626 Shares of eBay Inc. (NASDAQ:EBAY)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.americanbankingnews.com/2022/11/14/mitsubishi-ufj-trust-banking-corp-sells-28626-shares-of-ebay-inc-nasdaqebay.html" />
<meta property="og:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/ebay-inc-logo.png&amp;w=240&amp;h=240&amp;zc=2" />
<meta property="og:image:width" content="240" />
<meta property="og:image:height" content="240" />
<meta property="og:description" content="Mitsubishi UFJ Trust &#038; Banking Corp lessened its position in shares of eBay Inc. (NASDAQ:EBAY &#8211; Get Rating) by 3.2% in the second quarter, according to the company in its most recent disclosure with the Securities &amp; Exchange Commission. The firm owned 872,406 shares of the e-commerce company&#8217;s stock after selling 28,626 shares during the [&hellip;]" />
<meta property="og:site_name" content="American Banking News" />
<meta property="og:locale" content="en_US" />

<meta property="article:published_time" content="2022-11-14T07:46:42+0000" />
<meta property="article:modified_time" content="2022-11-14T07:46:42+0000" />
<meta property="article:tag" content="NASDAQ:EBAY" />
<meta property="article:tag" content="eBay,NASDAQ:EBAY,EBAY,Retail/Wholesale,27864210,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta property="article:section" content="Market News" />


<script type='text/javascript'>var PopupAdChannel=''; </script>
<link rel="manifest" href="/manifest.json">
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
<script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'americanbankingnews.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "e990a3cc-a882-4055-92e5-f5bbd425d86e",
      safari_web_id: 'web.onesignal.auto.66a57acb-1f7c-44c2-af57-20e68d9690d6', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}  </script>
<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>
<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=2021"></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: false
     });
</script>
</head>
<body data-rsssl=1>
<div id="wrap">
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=60"></script>

<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=12" />
<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-American Banking News', 'americanbankingnews.com', 'NASDAQ:EBAY', 'eBay', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/ebay-inc-logo.png');</script>

<a class="skip-link scroll" href="#main">Skip to main content</a>
<header>
<div class="width-limiter background-light top-menu-bar">
<div style='color:#222;text-align:right;'>
<nav class="navigation top-menu" aria-label="Utility Links"><ul id="menu-top-pages" class="menu"><li id="menu-item-5645782" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5645782"><a href="https://www.americanbankingnews.com/">Home</a></li>
<li id="menu-item-5636672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636672"><a href="https://www.americanbankingnews.com/about">About</a></li>
<li id="menu-item-5636674" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636674"><a href="https://www.americanbankingnews.com/daily-email-updates-basic">Newsletter</a></li>
<li id="menu-item-5636671" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636671"><a href="https://www.americanbankingnews.com/privacy-policy">Privacy</a></li>
<li id="menu-item-5636673" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636673"><a href="https://www.americanbankingnews.com/contact">Contact</a></li>
</ul></nav> </div>
</div>

<div class="width-limiter top-mobile-menu" id='mobile-logo-bar'>
<label for="nav-trigger" style="display:inline-block; width:30vw; color:#12424d;vertical-align:middle;">&#9776;</label>
<a style='vertical-align:middle;width:33vw;display:inline-block;text-align:center;padding:5px;' href="https://www.americanbankingnews.com"><img style='width:120px' src="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-and-market-news-logo-2020-gradient-04.png" alt="American Banking News logo" width="415" height="152"></a>
</div>
<div class="width-limiter" style="min-height: 5px;" id='mobile-menu-bar'>
<input type="checkbox" id="nav-trigger" class="navOpen" />
<div class="mobile-nav nice-scroll">
<nav class="mobile-menu" aria-label="Category Mobile Menu"><ul id="menu-categories" class="menu"><li id="menu-item-5637870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637870"><a href="https://www.americanbankingnews.com/category/market-news/analyst-articles-us">Analyst Ratings</a></li>
<li id="menu-item-5637876" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637876"><a href="https://www.americanbankingnews.com/category/market-news/dividend-articles">Dividends</a></li>
<li id="menu-item-5637877" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5637877"><a href="https://www.americanbankingnews.com/category/market-news/earnings-articles-single">Earnings</a>
<ul class="sub-menu">
<li id="menu-item-5645772" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645772"><a href="https://www.americanbankingnews.com/category/market-news/guidance-articles">Guidance</a></li>
</ul>
</li>
<li id="menu-item-5645779" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645779"><a href="https://www.americanbankingnews.com/category/market-news/price-articles">Highs and Lows</a></li>
<li id="menu-item-5637879" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637879"><a href="https://www.americanbankingnews.com/category/market-news/ipo-articles">IPOS</a></li>
<li id="menu-item-5645780" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645780"><a href="https://www.americanbankingnews.com/category/market-news/options-articles">Options</a></li>
<li id="menu-item-5637880" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5637880"><a href="https://www.americanbankingnews.com/category/market-news/sec-filing-articles">SEC Filings</a></li>
</ul></nav> <nav class="mobile-menu" aria-label="Utility Mobile Menu"><ul id="menu-top-pages-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5645782"><a href="https://www.americanbankingnews.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636672"><a href="https://www.americanbankingnews.com/about">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636674"><a href="https://www.americanbankingnews.com/daily-email-updates-basic">Newsletter</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636671"><a href="https://www.americanbankingnews.com/privacy-policy">Privacy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5636673"><a href="https://www.americanbankingnews.com/contact">Contact</a></li>
</ul></nav>
<form class="mobile-search" id="mobileSearchForm" action="https://www.americanbankingnews.com/" method="get">
<div class="search">
<input id="s" style='margin-left:0;' class="searchinput" aria-label="Search Keywords" name="s" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
<div>
</div>
</div>
</div>

<div class="width-limiter add-padding flex-container">
<a class="logo-link flex-logo" id="header-logo-link" href="https://www.americanbankingnews.com" title="American Banking News"><img id="logo" src="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-and-market-news-logo-2020-gradient-04.png" alt="American Banking News logo" width="415" height="152"></a>

<div id="AlternateHeaderUnit" class="flex-header-ad">
<iframe class="large-show" src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="110" frameborder="no" scrolling="no" style="width: 100%;overflow:hidden;" title="Ad"></iframe>
<iframe class="small-show" src="https://marketbeat.com/scripts/SidebarAdNewsSites.ashx" width="336" height="280" frameborder="no" scrolling="no" style="overflow:hidden;margin:0 auto;" title="Ad"></iframe>
</div>

</div> 
<div id="menu">
<div class="width-limiter flex-container" id="nav-main">

<div class="flex-nav">
<nav class="navigation" aria-label="Main Menu"><ul id="menu-categories-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637870"><a href="https://www.americanbankingnews.com/category/market-news/analyst-articles-us">Analyst Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637876"><a href="https://www.americanbankingnews.com/category/market-news/dividend-articles">Dividends</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5637877"><a href="https://www.americanbankingnews.com/category/market-news/earnings-articles-single">Earnings</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645772"><a href="https://www.americanbankingnews.com/category/market-news/guidance-articles">Guidance</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645779"><a href="https://www.americanbankingnews.com/category/market-news/price-articles">Highs and Lows</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637879"><a href="https://www.americanbankingnews.com/category/market-news/ipo-articles">IPOS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645780"><a href="https://www.americanbankingnews.com/category/market-news/options-articles">Options</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5637880"><a href="https://www.americanbankingnews.com/category/market-news/sec-filing-articles">SEC Filings</a></li>
</ul></nav>
</div>
<form class="flex-search" id="searchform" action="https://www.americanbankingnews.com/" method="get">
<div class="search">
<input id="s-main" class="searchinput" name="s" aria-label="Search Keywords" onclick="this.value='';" type="text" />
<input class="searchsubmit" type="submit" value="SEARCH" />
</div>
</form>
</div> 
</div> 
</header> 
<div class="width-limiter main-content flex-container">
<main class="flex-main" id="main">
<article itemscope itemtype="http://schema.org/NewsArticle">
<link itemprop="mainEntityOfPage" href="https://www.americanbankingnews.com/2022/11/14/mitsubishi-ufj-trust-banking-corp-sells-28626-shares-of-ebay-inc-nasdaqebay.html" />
<h1 itemprop="headline" class="page-title">Mitsubishi UFJ Trust &#038; Banking Corp Sells 28,626 Shares of eBay Inc. (NASDAQ:EBAY)</h1>
<p class="postmeta">
Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.americanbankingnews.com/author/Matt" title="Posts by ABMN Staff" rel="author">ABMN Staff</a></span></span> on <span itemprop="datePublished dateModified" content="2022-11-14T07:46:42+0000">Nov 14th, 2022</span>
</p>
<div class="social-shares">
<a title="Share on Twitter" rel="noopener nofollow" target="_blank" style="background: #1DA1F2;" href="https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Fwww.americanbankingnews.com&ref_src=twsrc%5Etfw&text=Mitsubishi%20UFJ%20Trust%20%26%20Banking%20Corp%20Sells%2028%2C626%20Shares%20of%20eBay%20Inc.%20%28NASDAQ%3AEBAY%29%20%24EBAY&tw_p=tweetbutton&url=https%3A%2F%2Fwww.americanbankingnews.com%2F2022%2F11%2F14%2Fmitsubishi-ufj-trust-banking-corp-sells-28626-shares-of-ebay-inc-nasdaqebay.html&via=AmericanBanking"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z" /></svg></span><span class="share-title">Share on Twitter</span></a>
<a title="Share on Facebook" rel="noopener nofollow" target="_blank" style="background:#4267B2;" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.americanbankingnews.com%2F2022%2F11%2F14%2Fmitsubishi-ufj-trust-banking-corp-sells-28626-shares-of-ebay-inc-nasdaqebay.html"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z" /></svg></span><span class="share-title">Share on Facebook</span></a>
<a title="Share on LinkedIn" rel="noopener nofollow" target="_blank" style="background: #0067b1;" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.americanbankingnews.com%2F2022%2F11%2F14%2Fmitsubishi-ufj-trust-banking-corp-sells-28626-shares-of-ebay-inc-nasdaqebay.html"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z" /></svg></span><span class="share-title">Share on LinkedIn</span></a>
<a title="Share on Stocktwits" rel="noopener nofollow" style="background:#228dff;" href="https://api.stocktwits.com/widgets/share?via=MarketBeat&amp;body=Mitsubishi%20UFJ%20Trust%20%26%20Banking%20Corp%20Sells%2028%2C626%20Shares%20of%20eBay%20Inc.%20%28NASDAQ%3AEBAY%29%20%24EBAY" title="Share on StockTwits"><span class="share-button"><svg style="fill:#fff;" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="24" height="24" viewBox="0 0 30 30" style="enable-background:new 0 0 30 30;" xml:space="preserve"><polygon class="st0" points="21.98,17.75 21.98,13.29 14.54,9.67 21.98,6.19 21.98,1.84 9.02,8.45 9.02,11.12 " /><polygon class="st0" points="9.07,13.19 9.07,17.65 16.49,21.27 9.07,24.76 9.07,29.1 21.98,22.49 21.98,19.82 " /></svg></span><span class="share-title">Share on Stocktwits</span></a>
</div>
<div style="clear:both"></div>

<div class="entry" itemprop="articleBody">

<iframe src="https://www.marketbeat.com/scripts/TextAdNewsSites.ashx?color=75411d" frameborder=no width="100%" height="35" scrolling="no" title="Advertisement"></iframe>
<p><img height="150" width="250" src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&h=150&zc=2&src=https://www.marketbeat.com/logos/ebay-inc-logo.png" alt="eBay logo" title="eBay" class="companylogo" />Mitsubishi UFJ Trust &#038; Banking Corp lessened its position in shares of eBay Inc. (<a href="https://www.marketbeat.com/stocks/NASDAQ/EBAY/">NASDAQ:EBAY</a> &#8211; <a style="font-weight:normal;text-decoration:italic;color:green" href="https://report.stocknews.com/sign-up/ticker/?ticker=EBAY&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=EBAY&#038;utm_content=text_link">Get Rating</a>) by 3.2% in the second quarter, according to the company in its most recent disclosure with the Securities &amp; Exchange Commission. The firm owned 872,406 shares of the e-commerce company&#8217;s stock after selling 28,626 shares during the period. Mitsubishi UFJ Trust &#038; Banking Corp owned approximately 0.16% of eBay worth $36,353,000 at the end of the most recent quarter. </p>
<p>Other institutional investors and hedge funds also recently made changes to their positions in the company. EverSource Wealth Advisors LLC grew its stake in shares of eBay by 78.2% in the second quarter. EverSource Wealth Advisors LLC now owns 672 shares of the e-commerce company&#8217;s stock valued at $28,000 after acquiring an additional 295 shares in the last quarter. Curi Wealth Management LLC grew its position in shares of eBay by 2,345.9% during the 2nd quarter. Curi Wealth Management LLC now owns 905 shares of the e-commerce company&#8217;s stock worth $38,000 after purchasing an additional 868 shares in the last quarter. CX Institutional bought a new position in shares of eBay during the second quarter worth approximately $41,000. Investors Asset Management of Georgia Inc. GA ADV acquired a new stake in shares of eBay in the second quarter valued at approximately $42,000. Finally, MCF Advisors LLC bought a new stake in shares of eBay in the first quarter valued at approximately $59,000. Institutional investors and hedge funds own 87.00% of the company&#8217;s stock. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
<input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-American Banking News" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:EBAY" /> <label for="InPostRegistrationEmail">Get <b>eBay</b> alerts:</label>
<div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 0.9em;line-height: 1em;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" class="button" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;font-size: 0.9em;font-weight: 700;line-height: 1em;padding: 6px 18px"></div>
</form>
<div id="ShowSuggestionInPost"></div>
<h2>eBay Stock Up 4.1 %</h2>
<p><a href='https://www.marketbeat.com/stocks/NASDAQ/EBAY/sec-filings/' target='_blank' rel="noopener">EBAY</a> opened at $46.51 on Monday. The company&#8217;s 50 day moving average price is $39.96 and its two-hundred day moving average price is $43.97. eBay Inc. has a fifty-two week low of $35.92 and a fifty-two week high of $76.58. The company has a debt-to-equity ratio of 1.36, a current ratio of 1.33 and a quick ratio of 1.33. </p>
<h2>eBay Announces Dividend</h2>
<p>
<div class="in-article-ad" class="width:340px;">
<iframe src="https://marketbeat.com/scripts/336x280AdNewsSites.ashx" width="336" height="280" frameborder="no" title="Offer"></iframe>
</div>
The business also recently disclosed a quarterly dividend, which will be paid on Friday, December 16th. Investors of record on Thursday, December 1st will be issued a $0.22 dividend. The ex-dividend date is Wednesday, November 30th. This represents a $0.88 dividend on an annualized basis and a yield of 1.89%. eBay&#8217;s payout ratio is -800.00%. </p>
<h2>Insider Buying and Selling</h2>
<p>In other eBay news, Director <a target='_blank' rel="noopener" href='https://www.insidertrades.com/ebay-inc-stock/robert-holmes-swan/'>Robert Holmes Swan</a> sold 25,000 shares of the company&#8217;s stock in a transaction dated Wednesday, October 26th. The stock was sold at an average price of $40.00, for a total value of $1,000,000.00. Following the sale, the director now owns 155,248 shares in the company, valued at approximately $6,209,920. The transaction was disclosed in a filing with the Securities &amp; Exchange Commission, which is available at <a href="https://www.sec.gov/Archives/edgar/data/1065088/000121836322000012/xslF345X03/edgardoc.xml" target='_blank' rel="noopener">this link</a>. In other eBay news, Director <a target='_blank' rel="noopener" href='https://www.insidertrades.com/ebay-inc-stock/robert-holmes-swan/'>Robert Holmes Swan</a> sold 25,000 shares of the stock in a transaction that occurred on Wednesday, October 26th. The shares were sold at an average price of $40.00, for a total transaction of $1,000,000.00. Following the completion of the sale, the director now owns 155,248 shares of the company&#8217;s stock, valued at approximately $6,209,920. The transaction was disclosed in a legal filing with the Securities &amp; Exchange Commission, which is accessible through <a href="https://www.sec.gov/Archives/edgar/data/1065088/000121836322000012/xslF345X03/edgardoc.xml" target='_blank' rel="noopener">the SEC website</a>. Also, CAO <a target='_blank' rel="noopener" href='https://www.insidertrades.com/ebay-inc-stock/brian-j-doerger/'>Brian J. Doerger</a> sold 4,311 shares of the business&#8217;s stock in a transaction that occurred on Tuesday, November 8th. The stock was sold at an average price of $41.89, for a total transaction of $180,587.79. Following the completion of the transaction, the chief accounting officer now owns 9,542 shares in the company, valued at approximately $399,714.38. The disclosure for this sale can be found <a href="https://www.sec.gov/Archives/edgar/data/1065088/000154905122000025/xslF345X03/edgardoc.xml" target='_blank' rel="noopener">here</a>. 0.17% of the stock is owned by corporate insiders. </p>
<h2>Analyst Upgrades and Downgrades</h2>
<p>A number of research firms have commented on EBAY. Needham &#038; Company LLC began coverage on eBay in a research note on Monday, August 1st. They set a &#8220;hold&#8221; rating on the stock. Barclays dropped their price target on eBay from $59.00 to $56.00 and set an &#8220;overweight&#8221; rating for the company in a research note on Thursday, November 3rd. Morgan Stanley increased their price objective on shares of eBay from $33.00 to $34.00 and gave the stock an &#8220;underweight&#8221; rating in a research note on Thursday, November 3rd. Robert W. Baird cut their price target on shares of eBay from $60.00 to $55.00 and set an &#8220;outperform&#8221; rating for the company in a report on Thursday, November 3rd. Finally, Truist Financial decreased their price objective on shares of eBay from $60.00 to $48.00 and set a &#8220;hold&#8221; rating on the stock in a research note on Monday, October 24th. Two equities research analysts have rated the stock with a sell rating, sixteen have assigned a hold rating and eight have given a buy rating to the stock. According to data from MarketBeat, the company has a consensus rating of &#8220;Hold&#8221; and an average price target of $52.50.</p>
<h2 style='display:inline-block'>eBay Profile</h2>
<p> (<a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=EBAY&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=EBAY&#038;utm_content=text_link'>Get Rating</a>)</p>
<p>eBay Inc operates marketplace platforms that connect buyers and sellers in the United States and internationally. The company&#x27;s Marketplace platform includes its online marketplace at ebay.com and the eBay suite of mobile apps. Its platforms enable users to list, buy, sell, and pay for items through various online, mobile, and offline channels that include retailers, distributors, liquidators, import and export companies, auctioneers, catalog and mail-order companies, directories, search engines, commerce participants, shopping channels, and networks.</p>
<h2>Read More</h2>
<ul>
<li><a href='https://report.stocknews.com/sign-up/ticker/?ticker=EBAY&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=EBAY&#038;utm_content=text_link' target='_blank' rel="noopener">Get a free copy of the StockNews.com research report on eBay (EBAY)</a></li>
<li><a href='https://www.marketbeat.com/originals/alphabet-stock-offers-a-rare-buying-opportunity/' target='_blank' rel="noopener">Alphabet Stock Offers a Rare Buying Opportunity </a></li>
<li><a href='https://www.marketbeat.com/originals/walt-disney-stock-is-set-to-reset-expectations/' target='_blank' rel="noopener">Walt Disney Stock is Set to Reset Expectations </a></li>
<li><a href='https://www.marketbeat.com/originals/solar-battery-maker-enphase-clears-buy-point-can-rally-hold/' target='_blank' rel="noopener">Solar Battery Maker Enphase Clears Buy Point: Can Rally Hold? </a></li>
<li><a href='https://www.marketbeat.com/originals/s-and-p-500-component-dexcom-set-for-further-price-earnings-growth/' target='_blank' rel="noopener">S&#038;P 500 Component DexCom Set For Further Price, Earnings Growth</a></li>
<li><a href='https://www.marketbeat.com/originals/marketbeat-week-in-review-11-7-11-11/' target='_blank' rel="noopener">MarketBeat: Week in Review 11/7 – 11/11</a></li>
</ul>
<p></p>
<p style="text-align:center"><img loading="lazy" src="https://www.marketbeat.com/scripts/SECFilingChart.ashx?Prefix=NASDAQ&#038;Symbol=EBAY" alt="Institutional Ownership by Quarter for eBay (NASDAQ:EBAY)" width="650" height="350" /></p>
<p></p>





<p style="clear:both"><strong>Receive News &amp; Ratings for eBay Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for eBay and related companies with <a href="/daily-email-updates-basic/?symbol=NASDAQ:EBAY&c=eBay" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address" class="signup" />
<input type="hidden" id="Hidden3" name="RegistrationCode" value="American Banking News-Footer" />
<input type="hidden" id="Hidden4" name="RegisterTicker" value="NASDAQ:EBAY" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>

</div> 


<div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=500&h=300&zc=2&src=https://www.marketbeat.com/logos/ebay-inc-logo.png" />
<meta itemprop="width" content="500">
<meta itemprop="height" content="300">
</div>
<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://www.americanbankingnews.com/wp-content/uploads/2020/11/american-banking-and-market-news-logo-2020-gradient-04.png">
<meta itemprop="width" content="415">
<meta itemprop="height" content="152">
</div>
<meta itemprop="name" content="American Banking News" />
<meta itemprop="url" content="https://americanbankingnews.com" />
</div>

</article>

<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx" title="More Headlines"></iframe>


<nav id="prevnext">
<a href="https://www.americanbankingnews.com/2022/11/14/kellogg-nysek-shares-purchased-by-mitsubishi-ufj-trust-banking-corp.html" rel="prev"><div class="previous"><h2 class="h4">&laquo; PREVIOUS HEADLINE</h2><p>Kellogg (NYSE:K) Shares Purchased by Mitsubishi UFJ Trust &#038; Banking Corp</p></div></a>
</nav>
<div id="latest-news">
<h2>You might be interested in:</h2>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/ebay-inc-logo.png&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Mitsubishi UFJ Trust &#038; Banking Corp Sells 28,626 Shares of eBay Inc. " />
</div></div>

<a href="https://www.americanbankingnews.com/2022/11/14/mitsubishi-ufj-trust-banking-corp-sells-28626-shares-of-ebay-inc-nasdaqebay.html" rel="bookmark">Mitsubishi UFJ Trust &#038; Banking Corp Sells 28,626 Shares of eBay Inc. </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/kellogg-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Kellogg  Shares Purchased by Mitsubishi UFJ Trust &#038; Banking Corp" />
</div></div>

<a href="https://www.americanbankingnews.com/2022/11/14/kellogg-nysek-shares-purchased-by-mitsubishi-ufj-trust-banking-corp.html" rel="bookmark">Kellogg Shares Purchased by Mitsubishi UFJ Trust &#038; Banking Corp</a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/archer-daniels-midland-co-logo.jpg?v=20200424121557&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Mitsubishi UFJ Trust &#038; Banking Corp Acquires 5,199 Shares of Archer-Daniels-Midland Company " />
</div></div>

<a href="https://www.americanbankingnews.com/2022/11/14/mitsubishi-ufj-trust-banking-corp-acquires-5199-shares-of-archer-daniels-midland-company-nyseadm.html" rel="bookmark">Mitsubishi UFJ Trust &#038; Banking Corp Acquires 5,199 Shares of Archer-Daniels-Midland Company </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/franco-nevada-co-logo.png?v=20221103120812&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Swiss National Bank Has $112.36 Million Stock Position in Franco-Nevada Co. " />
</div></div>

<a href="https://www.americanbankingnews.com/2022/11/14/swiss-national-bank-has-112-36-million-stock-position-in-franco-nevada-co-nysefnv.html" rel="bookmark">Swiss National Bank Has $112.36 Million Stock Position in Franco-Nevada Co. </a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/mccormick--company-incorporated-logo.png?v=20221103135640&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="McCormick &#038; Company, Incorporated  Shares Bought by Swiss National Bank" />
</div></div>

<a href="https://www.americanbankingnews.com/2022/11/14/mccormick-company-incorporated-nysemkc-shares-bought-by-swiss-national-bank.html" rel="bookmark">McCormick &#038; Company, Incorporated Shares Bought by Swiss National Bank</a>
</div>
<div class="latest-news-item">
<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/coterra-energy-inc-logo.jpg?v=20211104092410&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Swiss National Bank Raises Holdings in Coterra Energy Inc. " />
</div></div>

<a href="https://www.americanbankingnews.com/2022/11/14/swiss-national-bank-raises-holdings-in-coterra-energy-inc-nysectra.html" rel="bookmark">Swiss National Bank Raises Holdings in Coterra Energy Inc. </a>
</div>
</div>

<br>
</main> 
<aside class="flex-sidebar">
<div class="flex-container">
<div class="sidebar-section">

<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no" title="More Articles"></iframe><br><br>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>

<br><br>


<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>

<br><br>

</div>
<div class="sidebar-section">


<div class="sidebar-email">
<h3>Daily Ratings &amp; News for eBay</h3>
Complete the form below to receive the latest headlines and analysts' recommendations for eBay with our free daily email newsletter:<br />
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="RegisterEmailSidebar" style='width:100%' name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address">
<input type="hidden" id="Hidden7" name="RegistrationCode" value="American Banking News-Sidebar">
<input type="hidden" id="Hidden8" name="RegisterTicker" value="NASDAQ:EBAY" /> <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:100%;height:30px">
<div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
</form>
</div>


<br>
<a style="background: #075A8D;color: #fff;padding: 5px 7px 4px;border-radius: 3px;font-size: 12px;text-decoration: none;" href="https://twitter.com/intent/follow?original_referer=https%3A%2F%2Fwww.americanbankingnews.com%2F&ref_src=twsrc%5Etfw&screen_name=AmericanBanking" target="_blank" rel="noopener nofollow">
<svg style="width: 13px;vertical-align: middle;margin-right: 4px;fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z" /></svg> Follow @AmericanBanking</a>



<br />
<div>
<h3>Recent News</h3>
<ul>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/mitsubishi-ufj-trust-banking-corp-sells-28626-shares-of-ebay-inc-nasdaqebay.html">Mitsubishi UFJ Trust &#038; Banking Corp Sells 28,626 Shares of eBay Inc. (NASDAQ:EBAY)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/kellogg-nysek-shares-purchased-by-mitsubishi-ufj-trust-banking-corp.html">Kellogg (NYSE:K) Shares Purchased by Mitsubishi UFJ Trust &#038; Banking Corp</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/mitsubishi-ufj-trust-banking-corp-acquires-5199-shares-of-archer-daniels-midland-company-nyseadm.html">Mitsubishi UFJ Trust &#038; Banking Corp Acquires 5,199 Shares of Archer-Daniels-Midland Company (NYSE:ADM)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/swiss-national-bank-has-112-36-million-stock-position-in-franco-nevada-co-nysefnv.html">Swiss National Bank Has $112.36 Million Stock Position in Franco-Nevada Co. (NYSE:FNV)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/mccormick-company-incorporated-nysemkc-shares-bought-by-swiss-national-bank.html">McCormick &#038; Company, Incorporated (NYSE:MKC) Shares Bought by Swiss National Bank</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/swiss-national-bank-raises-holdings-in-coterra-energy-inc-nysectra.html">Swiss National Bank Raises Holdings in Coterra Energy Inc. (NYSE:CTRA)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/swiss-national-bank-sells-8200-shares-of-tyson-foods-inc-nysetsn.html">Swiss National Bank Sells 8,200 Shares of Tyson Foods, Inc. (NYSE:TSN)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/keysight-technologies-inc-nysekeys-shares-sold-by-swiss-national-bank.html">Keysight Technologies, Inc. (NYSE:KEYS) Shares Sold by Swiss National Bank</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/swiss-national-bank-has-90-45-million-stock-position-in-ansys-inc-nasdaqanss.html">Swiss National Bank Has $90.45 Million Stock Position in ANSYS, Inc. (NASDAQ:ANSS)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/mitsubishi-ufj-trust-banking-corp-buys-7248-shares-of-oreilly-automotive-inc-nasdaqorly.html">Mitsubishi UFJ Trust &#038; Banking Corp Buys 7,248 Shares of O&#8217;Reilly Automotive, Inc. (NASDAQ:ORLY)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/weyerhaeuser-nysewy-shares-sold-by-swiss-national-bank.html">Weyerhaeuser (NYSE:WY) Shares Sold by Swiss National Bank</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/enphase-energy-inc-nasdaqenph-shares-bought-by-swiss-national-bank.html">Enphase Energy, Inc. (NASDAQ:ENPH) Shares Bought by Swiss National Bank</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/take-two-interactive-software-inc-nasdaqttwo-shares-purchased-by-swiss-national-bank.html">Take-Two Interactive Software, Inc. (NASDAQ:TTWO) Shares Purchased by Swiss National Bank</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/eqis-capital-management-inc-buys-123-shares-of-jpmorgan-chase-co-nysejpm.html">Eqis Capital Management Inc. Buys 123 Shares of JPMorgan Chase &#038; Co. (NYSE:JPM)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/illumina-inc-nasdaqilmn-shares-sold-by-eqis-capital-management-inc.html">Illumina, Inc. (NASDAQ:ILMN) Shares Sold by Eqis Capital Management Inc.</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/argent-advisors-inc-raises-position-in-jpmorgan-chase-co-nysejpm.html">Argent Advisors Inc. Raises Position in JPMorgan Chase &#038; Co. (NYSE:JPM)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/duality-advisers-lp-takes-5-74-million-position-in-jpmorgan-chase-co-nysejpm.html">Duality Advisers LP Takes $5.74 Million Position in JPMorgan Chase &#038; Co. (NYSE:JPM)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/advisors-asset-management-inc-has-2-13-million-holdings-in-keurig-dr-pepper-inc-nasdaqkdp.html">Advisors Asset Management Inc. Has $2.13 Million Holdings in Keurig Dr Pepper Inc. (NASDAQ:KDP)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/advisors-asset-management-inc-reduces-stake-in-d-r-horton-inc-nysedhi.html">Advisors Asset Management Inc. Reduces Stake in D.R. Horton, Inc. (NYSE:DHI)</a></li>
<li class="recent-posts"><a href="https://www.americanbankingnews.com/2022/11/14/oppenheimer-asset-management-inc-reduces-holdings-in-euronet-worldwide-inc-nasdaqeeft.html">Oppenheimer Asset Management Inc. Reduces Holdings in Euronet Worldwide, Inc. (NASDAQ:EEFT)</a></li>
</ul>
</div>
</div>
</div>

</aside>
<div style="clear: both;"></div>
</div> 
<footer class="full-width">
<div class="width-limiter flex-container">
<div id="footer-info" class="add-padding flex-nav">
<nav class="navigation" aria-label="Category Links"><ul id="menu-categories-2" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637870"><a href="https://www.americanbankingnews.com/category/market-news/analyst-articles-us">Analyst Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637876"><a href="https://www.americanbankingnews.com/category/market-news/dividend-articles">Dividends</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5637877"><a href="https://www.americanbankingnews.com/category/market-news/earnings-articles-single">Earnings</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645772"><a href="https://www.americanbankingnews.com/category/market-news/guidance-articles">Guidance</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645779"><a href="https://www.americanbankingnews.com/category/market-news/price-articles">Highs and Lows</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5637879"><a href="https://www.americanbankingnews.com/category/market-news/ipo-articles">IPOS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5645780"><a href="https://www.americanbankingnews.com/category/market-news/options-articles">Options</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5637880"><a href="https://www.americanbankingnews.com/category/market-news/sec-filing-articles">SEC Filings</a></li>
</ul></nav> </div>
<span id="copyright" class="add-padding flex-copyright">
&copy; 2018-2022 <a href="https://www.americanbankingnews.com">American Banking News</a>
</span>
</div>

<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/viewcount.ashx?ArticleHistoryID=98127586&PostDate=2022-11-14&type=f&id=13245958&domain=www.americanbankingnews.com&referrer=' + encodeURIComponent(document.referrer) + '" alt="" width="1" height="1" style="float:left;" />');</script>

</footer>
</div>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-3019647-13"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-3019647-13');
</script>


<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1" alt=""></noscript>


<script type="text/javascript">
var sc_project=4951918; 
var sc_invisible=1; 
var sc_security="f1c0d9fb"; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/4951918/0/f1c0d9fb/1/" height="1" width="1"  alt=""></noscript>

</body>
</html>
